Wine: Porovnání verzí

Přidáno 6 513 bajtů ,  před 1 rokem
Problémy
(Problémy)
** 145K ASYCFILT.DLL
** 1,4M MSVBVM60.DLL
 
== Problémy ==
Spustím:
wine64-stable /WIN/BTL08Win/Ecg.exe
wine: created the configuration directory '/home/petr/.wine'
wine: could not exec wineserver
 
Tak si říkám, že mi asi chybí něco v instalaci, takže se pokusím to celé přeinstalovat
 
Pustím Synaptic
 
Hledat wine
 
Mám nainstalováno:
* wine32:i386
* wine64
 
Kromě toho tu mám v nabídce m.j.:
* wine-stable
* wine1.6
 
Vyhledám:
* https://wiki.ubuntu.cz/wine
 
Doporučují nainstalovat wine1.6
 
Tak tedy v Synapticu dám purge
* wine32:i386
* wine64
 
Ale když chci nainstalovat buď wine-stable anebo wine1.6, tak se mi tam rozsvítí červený vykřičník, jakože 1 problémová. Která to je?
sudo apt-get -f install
 
Označí mi to hromadu věcí, hlavně knihoven, že prý už nejsou potřeba
 
Pro jejich odstranění použijte „sudo apt autoremove“.
 
Raději nejdříve spustím Systém->Ubuntu cleaner
 
<pre>
sudo apt-get install wine-stable
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:
 
Následující balíky mají nesplněné závislosti:
wine-stable : Závisí na: wine-stable-amd64 (= 4.0.1~cosmic) ale nebude se instalovat
Závisí na: wine-stable-i386 (= 4.0.1~cosmic)
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
</pre>
 
<pre>
sudo apt-get install wine1.6
 
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:
 
Následující balíky mají nesplněné závislosti:
wine1.6 : Závisí na: wine-stable
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
<pre>
 
<pre>
sudo apt-get install wine-stable-i386
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:
 
Následující balíky mají nesplněné závislosti:
wine-stable-i386:i386 : Závisí na: libc6:i386 (>= 2.28) ale 2.27-3ubuntu1.2 se bude instalovat
Závisí na: libvkd3d1:i386 ale nedá se nainstalovat
Doporučuje: libcapi20-3:i386 ale nebude se instalovat
Doporučuje: libcups2:i386 ale nebude se instalovat
Doporučuje: libglu1-mesa:i386 ale nebude se instalovat nebo
libglu1:i386
Doporučuje: libgsm1:i386 ale nebude se instalovat
Doporučuje: libgssapi-krb5-2:i386 ale nebude se instalovat
Doporučuje: libkrb5-3:i386 ale nebude se instalovat
Doporučuje: libodbc1:i386 ale nebude se instalovat
Doporučuje: libosmesa6:i386 ale nebude se instalovat
Doporučuje: libsane:i386 nebo
libsane1:i386 ale nebude se instalovat
Doporučuje: libsdl2-2.0-0:i386 ale nebude se instalovat
Doporučuje: libv4l-0:i386 ale nebude se instalovat
Doporučuje: libxcomposite1:i386 ale nebude se instalovat
Doporučuje: libxcursor1:i386 ale nebude se instalovat
Doporučuje: libxfixes3:i386 ale nebude se instalovat
Doporučuje: libxi6:i386 ale nebude se instalovat
Doporučuje: libxinerama1:i386 ale nebude se instalovat
Doporučuje: libxrandr2:i386 ale nebude se instalovat
Doporučuje: libxrender1:i386 ale nebude se instalovat
Doporučuje: libxslt1.1:i386 ale nebude se instalovat
Doporučuje: libxxf86vm1:i386 ale nebude se instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
</pre>
 
<pre>
sudo apt-get install libvkd3d1:i386
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí
Načítají se stavové informace… Hotovo
Balík libvkd3d1:i386 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje
 
E: Balík „libvkd3d1:i386“ nemá kandidáta pro instalaci
</pre>
 
* [https://forum.winehq.org/viewtopic.php?t=31667 "Unmet dependencies" after linuxmmint 19 to 19.1 upgrade]
* [https://askubuntu.com/questions/1109474/cant-install-wine-ubuntu-18-04-dependencies-issues-solved Can't install Wine Ubuntu 18.04, dependencies issues SOLVED]
* [https://askubuntu.com/questions/1097724/cant-install-wine-ubuntu-18-04 Can't install Wine Ubuntu 18.04]
 
<pre>
sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport
sudo dpkg --add-architecture i386
wget -qO - https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -
sudo apt-add-repository "deb https://dl.winehq.org/wine-builds/ubuntu $(lsb_release -cs) main"
 
Následující balíky budou aktualizovány:
libfreetype6 libsdl2-2.0-0
2 aktualizováno, 155 nově instalováno, 0 k odstranění a 22 neaktualizováno.
Nutno stáhnout 187 MB archivů.
Po této operaci bude na disku použito dalších 1 353 MB.
Chcete pokračovat? [Y/n]
...
Nastavuje se balík wine-stable-i386:i386 (5.0.2~bionic) …
Nastavuje se balík wine-stable (5.0.2~bionic) …
Nastavuje se balík winehq-stable (5.0.2~bionic) …
...
</pre>
 
df -h
Souborový systém Velikost Užito Volno Uži% Připojeno do
/dev/nvme0n1p6 22G 15G 6,5G 69% /
/dev/nvme0n1p6 22G 16G 5,4G 74% /
 
Tak to skutečně sežralo 1,1 GB :-(
 
 
 
 
 
[[Kategorie:Software]]
12 021

editací